Ford Forums & Technical Discussions banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My '04 Lariat 5.4L A/C with automatic climate control started blowing cool intermittently. After adding coolant it was colder but still would turn warm occasionally. Then the blower stopped working entirely.
First checked/replaced fuses and relay. No change. Then replaced resistor with same results. Was thrilled after replacing the blower it was blowing real good. But not so fast.
Then the fun really started. First I noticed blower speed seemed to be pulsing. It was then I noticed the blower speed did not work, only blowing on high. Tried to turn off the fan and it would not turn off. Restarted the truck and blower was off. Pushed the fan or A/C button and blower would not work, and everything went haywire with shifter locking etc.
Turned blower off and restarted and the truck was good until I pushed that button. Sometimes the blower would come on at restart and the system was not turned on!
Started looking at ground wires. Replaced body to frame ground wire but no luck. Searched online, YouTube, Chiltons, can't find anything like this.
So winter is arriving here in Michigan and it looks like truck will sit until Spring!

Help! Thanks.
 

·
Super Moderator
Joined
·
127 Posts
Good idea to start with grounds - 18 year old truck in the rust belt is going to see weird wiring issues - how is the driver's side door jamb holding up? If I remember right, there is an important interior ground behind the kick panel near your left foot.
 
1 - 2 of 2 Posts
Top